Discussion:
[TeXlive 2021 pretest] LuaLaTeX Konlikt mit url.sty
(zu alt für eine Antwort)
Olaf Meltzer
2021-04-01 09:54:55 UTC
Permalink
Folgendes Minimalbeispiel

\documentclass[DIV=15]{scrartcl}
\usepackage{fontspec}
\usepackage{url}
\begin{document}
Kein weiterer Text
\end{document}

führt zu dem hier aus dem Emacs "TeX Help Buffer" zitierten Fehler.

ERROR: String contains an invalid utf-8 sequence.

--- TeX said ---
l.39 \do\
{\mathchar"3E }\do\{\mathchar"1B }\do\{{\mathchar"19 }%
--- HELP ---
From the .log file...

A funny symbol that I can't read has just been (re)read.
Just continue, I'll change it to 0xFFFD.

Im PDF erscheint auch folgender Text:

mathchar”1B mathchar”19 ̃̃
mathchar190 mathchar190 mathchar247 mathchar255 mathchar184

Woran mag das liegen?

Gruß -- Olaf Meltzer
Ulrike Fischer
2021-04-01 10:56:07 UTC
Permalink
Post by Olaf Meltzer
führt zu dem hier aus dem Emacs "TeX Help Buffer" zitierten Fehler.
Kein Problem hier. Zeig mal die log-Datei.
--
Ulrike Fischer
http://www.troubleshooting-tex.de/
Olaf Meltzer
2021-04-01 13:48:17 UTC
Permalink
Post by Ulrike Fischer
fÃŒhrt zu dem hier aus dem Emacs "TeX Help Buffer" zitierten Fehler.
Kein Problem hier. Zeig mal die log-Datei.
Mein jetzt noch minimaleres MB (mit article.cls statt scrartcl.cls)
zeigt denselben Fehler. Die resultierende Log-Datei findest Du im Anhang.

Gruß -- Olaf Meltzer
Olaf Meltzer
2021-04-01 14:26:28 UTC
Permalink
Post by Ulrike Fischer
Post by Olaf Meltzer
führt zu dem hier aus dem Emacs "TeX Help Buffer" zitierten Fehler.
Kein Problem hier. Zeig mal die log-Datei.
Spar Dir die Zeit, dort reinzusehen. Ich habe MEINEN Fehler gefunden. Im
lokalen TeX-Labor war noch ein experimenteller url.sty (von 2007!) in
Reichweite.

Tut mir leid -- Olaf Meltzer
Uwe Siart
2021-04-01 11:12:19 UTC
Permalink
Post by Olaf Meltzer
Folgendes Minimalbeispiel
\documentclass[DIV=15]{scrartcl}
\usepackage{fontspec}
\usepackage{url}
\begin{document}
Kein weiterer Text
\end{document}
führt zu dem hier aus dem Emacs "TeX Help Buffer" zitierten Fehler.
Läuft bei mir. Vielleicht ist deine Datei nicht UTF8-codiert.

Wenn du AUCTeX nimmst, mach mal ans Ende

%%% Local Variables:
%%% mode: latex
%%% TeX-master: t
%%% TeX-engine: luatex
%%% TeX-PDF-mode: t
%%% coding: utf-8-dos
%%% End:

und probier nach "C-c C-n" nochmal.
--
Uwe
Olaf Meltzer
2021-04-01 13:55:35 UTC
Permalink
Post by Uwe Siart
Post by Olaf Meltzer
Folgendes Minimalbeispiel
\documentclass[DIV=15]{scrartcl}
\usepackage{fontspec}
\usepackage{url}
\begin{document}
Kein weiterer Text
\end{document}
führt zu dem hier aus dem Emacs "TeX Help Buffer" zitierten Fehler.
Läuft bei mir. Vielleicht ist deine Datei nicht UTF8-codiert.
Wenn du AUCTeX nimmst, mach mal ans Ende
%%% mode: latex
%%% TeX-master: t
%%% TeX-engine: luatex
%%% TeX-PDF-mode: t
%%% coding: utf-8-dos
und probier nach "C-c C-n" nochmal.
Done. Provoziert denselben Fehler. Die *.tex-Quelldatei (das
Minimalbeispiel) selbst enthält ja keinerlei UTF8-Zeichen. Der Unfall
passiert beim einlesen des url.sty.

Gruß -- Olaf Meltzer
Olaf Meltzer
2021-04-01 14:29:01 UTC
Permalink
Post by Uwe Siart
Post by Olaf Meltzer
Folgendes Minimalbeispiel
\documentclass[DIV=15]{scrartcl}
\usepackage{fontspec}
\usepackage{url}
\begin{document}
Kein weiterer Text
\end{document}
führt zu dem hier aus dem Emacs "TeX Help Buffer" zitierten Fehler.
Läuft bei mir. Vielleicht ist deine Datei nicht UTF8-codiert.
Wenn du AUCTeX nimmst, mach mal ans Ende
%%% mode: latex
%%% TeX-master: t
%%% TeX-engine: luatex
%%% TeX-PDF-mode: t
%%% coding: utf-8-dos
und probier nach "C-c C-n" nochmal.
Es war -- wie eigentlich schon zu erwarten -- MEIN Fehler: Ein
experimenteller url.sty (von 2007!) war lokal zu erreichen.

Dumm gelaufen -- Olaf Meltzer

Lesen Sie weiter auf narkive:
Loading...