Discussion:
Schräges Problem mit Ligaturen in lualatex
(zu alt für eine Antwort)
Klaus Ethgen
2021-06-10 09:46:05 UTC
Permalink
Ich habe etwas mit lualatex experimentiert und bin über folgendes
Problem gestolpert:
\documentclass{article}
\usepackage{wela}

\begin{document}
\wela%
international
\end{document}

Unter pdflatex bekomme ich "international", aber unter lualatex bekomme
ich "iternational". Das "n" wird völlig unterdrückt.

Jemand eine Idee, weshalb?

-- Klaus
--
Klaus Ethgen http://www.ethgen.ch/
pub 4096R/4E20AF1C 2011-05-16 Klaus Ethgen <***@Ethgen.ch>
Fingerprint: 85D4 CA42 952C 949B 1753 62B3 79D0 B06F 4E20 AF1C
Tobias Dussa
2021-06-10 12:45:24 UTC
Permalink
Hi,
Post by Klaus Ethgen
Unter pdflatex bekomme ich "international", aber unter lualatex bekomme
ich "iternational". Das "n" wird völlig unterdrückt.
Ich habe zwar keine Idee, was der Grund ist, aber bei mir kommt sogar
nur »iterntional« raus (da fehlt auch noch das »a«)... Weird.

Cheers,
Toby.
--
Real programmers don't write in BASIC. Actually, no programmers write
in BASIC after reaching puberty.
Klaus Ethgen
2021-06-10 20:49:05 UTC
Permalink
Post by Tobias Dussa
Post by Klaus Ethgen
Unter pdflatex bekomme ich "international", aber unter lualatex bekomme
ich "iternational". Das "n" wird völlig unterdrückt.
Ich habe zwar keine Idee, was der Grund ist, aber bei mir kommt sogar
nur »iterntional« raus (da fehlt auch noch das »a«)... Weird.
Stimmt. bei mir auch. Ist mir noch garnicht aufgefallen.

Das Lustige ist ja, setze ich zwischen i und n (sowie zwischen n und a)
ein "| (und verwende babel), dann werden die Buchstaben angezeigt.
Allerdings stimmen dann die verbindungen nicht. Die Buchstaben alleine
("nat" oder "int") funktionieren problemlos.

Das spricht zumindest gegen die Theorie, daß lualatex kein wela könne.

Es sieht eher so aus, als ob lualatex da irgendwelche seltsame Magie
macht und das n und das a als überflüssig erachtet.

-- Klaus
--
Klaus Ethgen http://www.ethgen.ch/
pub 4096R/4E20AF1C 2011-05-16 Klaus Ethgen <***@Ethgen.ch>
Fingerprint: 85D4 CA42 952C 949B 1753 62B3 79D0 B06F 4E20 AF1C
Uwe Siart
2021-06-10 13:47:39 UTC
Permalink
Post by Klaus Ethgen
Ich habe etwas mit lualatex experimentiert und bin über folgendes
\documentclass{article}
\usepackage{wela}
\begin{document}
\wela%
international
\end{document}
Unter pdflatex bekomme ich "international", aber unter lualatex bekomme
ich "iternational". Das "n" wird völlig unterdrückt.
Jemand eine Idee, weshalb?
Lualatex verwendet OpenType- und TrueType-Schriften. Das Paket
'schulschriften' enthält aber Metafont-Files und erzeugt dann
Bitmap-Fonts (.pk-Dateien). Damit kann luatex soviel ich weiß nicht mehr
umgehen. Also um 'wela' zu verwenden, musst du bei pdflatex oder
latex+dvips bleiben.
--
Uwe
Tobias Dussa
2021-06-10 14:04:26 UTC
Permalink
Post by Uwe Siart
Post by Klaus Ethgen
Unter pdflatex bekomme ich "international", aber unter lualatex bekomme
ich "iternational". Das "n" wird völlig unterdrückt.
Jemand eine Idee, weshalb?
Lualatex verwendet OpenType- und TrueType-Schriften. Das Paket
'schulschriften' enthält aber Metafont-Files und erzeugt dann
Bitmap-Fonts (.pk-Dateien). Damit kann luatex soviel ich weiß nicht mehr
umgehen. Also um 'wela' zu verwenden, musst du bei pdflatex oder
latex+dvips bleiben.
Wenn das gar nicht damit könnte, dann würde ja doch vermutlich auch gar
nix rauskommen, oder täusche ich mich? :) Ganz so einfach ist es leider
nicht, denke ich.

Cheers,
Toby.
--
Real programmers don't write in BASIC. Actually, no programmers write
in BASIC after reaching puberty.
Uwe Siart
2021-06-10 16:10:05 UTC
Permalink
Post by Tobias Dussa
Wenn das gar nicht damit könnte, dann würde ja doch vermutlich auch
gar nix rauskommen, oder täusche ich mich? :) Ganz so einfach ist es
leider nicht, denke ich.
Das Paket 'schulschriften' unterstützt kein TU-Encoding. Vielleicht
liegt hier das Problem.
--
Uwe
Lesen Sie weiter auf narkive:
Loading...